This project has moved and is read-only. For the latest updates, please go here.

Can't run sample Windows Phone app

Jan 21, 2014 at 8:41 PM
Edited Jan 21, 2014 at 8:42 PM

I tried to run sample WP app you provided but when I load the solution I'm getting a lot of errors saying:
Error 1 The member "BrickInputPort" is not recognized or is not accessible. D:\Projekty\EV3\WP EV3 Samples.1.0.0\SampleApps\SampleApp (Phone)\MainPage.xaml 53 6 SampleApp (Phone)
etc. I'm using Visual Studio 2012. Is it because of that? If not how to fix it?
Jan 21, 2014 at 10:19 PM
Open the Lego.Ev3.SampleApps.sln solution file in the root directory instead of the csproj file deeper down. The samples use project references and they are setup properly when loading the .sln files.
Jan 21, 2014 at 11:38 PM
That's what I did but I'm still getting those errors.
Jan 21, 2014 at 11:40 PM
Have you tried a Rebuild All from the Build menu? You may be seeing those errors in the XAML designer because the supporting references have not yet been built. Otherwise, I'm not sure what the problem could be. Opening the .sln here and building the project works as expected...
Jan 22, 2014 at 12:40 AM
Rebuild helped, thank you. And I figured that on my own right before I saw your answer :)

Now I'll try to write my own app so I'll probably post some questions here in the next few days.
Mar 5, 2014 at 3:06 AM
Edited Mar 5, 2014 at 3:11 AM
The rebuild didn't work for me. I tried rebuilding many times, I tried opening the lower level csproj file and then opening the sln and still had the "The member "BrickInputPort" is not recognized or is not accessible". And the designer only displays the message "Invalid Markup Check the Error List for more information"

However, even with the error, the program did run and I was able to communicate with my EV3. But, it would be great to work with the designer in this project.

I'm running VS 2013 on Win7.
Mar 5, 2014 at 6:36 PM
Not sure what else to suggest...working here in VS2013 on Win8.1...Win7 shouldn't make a difference. Perhaps grab a fresh copy of the source and start again? Make sure you're using the .SampleApps solution file. Can you build any of the other projects?
Mar 5, 2014 at 9:27 PM
I tried a fresh copy of the source, with the same results. I am using the .SampleApps solution file. I am not able to build any of the other projects. With the phone app, I get "This project is incompatible with the current edition of Visual Studio" and with the WinRT project I get "Windows 8.1 required".

I am using Visual Studio Ultimate 2013.

Thanks for the help.
Mar 5, 2014 at 9:29 PM
Which version of the app are you trying to build? This thread was referring to the Phone app, but your last comment states the phone app is incompatible...
Mar 6, 2014 at 12:02 AM
I was trying the desktop app (since the Phone app was not compatible). However, it was the exact same error. Should I open a new thread?
Mar 6, 2014 at 3:33 AM
Yes, please.